ググると立ち上がらなくなったのオンパレード。
それにもめげず検索方法を変えて再度ググってみた所http://www.yec.or.jp/MT/archives/20040822213455.htmlのサイトにヒントが隠されていた。

「●「1分程お待ちください…」画面の再起動を繰り返すとき
qpeのバージョンのあっていないプラグインなどを入れる
と起こるということで、
/home/QtPalmtop/plugins/inputmethods/
下に怪しいファイルがあるとのこと。」との記述が。

更に、この方の場合、日本語対応するためのファイルという
・imkit-anthy
・libimkit-qpe
の2つがそれに当たっていたという。確かにおいらもそれを入れていた時に立ち上がらなくなっている。

今度はその2つを抜いてインストールすると、何度再起動しても大丈夫だった。あぁぁ、おいらの時間が…。
先人の皆さん、ありがとう。